Windows SatSYNC (v2.35.08) Installation Instructions

 

SatSYNC is the software program that allows your computer to recognise Satmap GPS devices when they are plugged into a USB port on your computer.

(Some of the information contained on Satmap GPS devices can only be seen on the SatSYNC window and not through Windows Explorer. SatSYNC has embedded route and track handling features, unavailable in Windows Explorer)

 

 
 
PLEASE NOTE:
If you are installing SatSYNC for the first time, or upgrading from SatSYNC v2.0.0.3399 or older, you will need the following Microsoft Visual C++ 2013 Redistributable toolset to be installed.
 

Supported Operating Systems:

  • Windows 7, 8, 10
  • Windows Vista
  • Windows XP - Not supported
 

Installation instructions

Download Instructions for SatSYNC for Windows

  1. If you don't already have SatSYNC installed, or you are upgrading from a version older than SatSYNC v2.0.0.3399, then please use the link above to install Microsoft Visual C++ 2013 Redistributable library. This is required by SatSYNC
  2. Click on the "Download" link to download your selected version
  3. When prompted with the "File Download - Security Warning" select "Save" and choose a memorable location on your computer to save the file (e.g. My Documents, Desktop).
  4. Once the download is complete double-click on the file to begin the installation.
  5. Select 'Run' to proceed with the installation.
  6. Follow the instructions in the installation wizard.
  7. You may be directed to the Microsoft website to download and install version 3.5, service pack 1 of the .NET framework before proceeding with the installation of SatSYNC. If .NET 3.5 SP1 does not work well on your machine, please let us know and contact Microsoft or your computer vendor for a solution.
  8. Please contact techsupport@satmap.com if you require more information
 

Previous Windows Versions

 

Please Note: If you wish to install a version of SatSYNC that is earlier than the one that you currently have installed, then you should first uninstall the current version before installing the older version.

 
30 Apr 2018
 
19 Apr 2018
 
15 Mar 2018
 
26 Feb 2018
 
19 Feb 2018
 
19 Jan 2018
 
18 Jan 2018
 
Contact Us